Picture of Admin Niuolahiki
Leopard, Not compatible with Leok?
by Admin Niuolahiki - Sunday, October 28, 2007, 04:07 PM
 
Apple Computer released a major upgrade to its operating system. Mac OS 10.5 also known as Leopard is not compatible with FirstClass. DO NOT INSTALL this operating system on your computer. If you do, you will not be able to access your online textbook.

We will be testing Leopard in the next few weeks.